Recommended JRuby Install For JRubyArt

The preferred JRubyArt setup requires that you do a system install of JRuby. You should install java before attempting to install JRuby. Install at least version 9.3.0.0.

Alternative Setup For JRubyArt

It is possible to use JRubyArt without doing a system install, by using JRuby-Complete. You do need to install java and MRI ruby. However you will not be able to install certain gems with this setup.